Pourquoi changer la version de PHP de son hébergement cPanel ?

Nous recommandons de mettre à jour régulièrement votre version de PHP. Cela améliore la performance et la sécurité de votre site.

Pourquoi ce changement de version de PHP n’est-il pas automatique ?

Changer la version PHP d’un site nécessite de vérifier ensuite le bon fonctionnement de celui-ci. Pour cette raison nous ne changeons pas votre version de PHP automatiquement.

Est-ce qu’utiliser une ancienne version de PHP est un risque de sécurité ?

Sur nos hébergements web, ne pas utiliser une version récente ne présente pas de risque de sécurité. Cela est possible grâce à la sécurité “Hardened PHP” de CloudLinux qui corrige les failles de sécurité dans les versions de PHP qui ne sont plus maintenus par les équipes de PHP.

Si vous utilisez une ancienne version de PHP parce qu’une de vos applications n’est pas compatible avec une version récente de PHP, assurez-vous que votre application n’est pas un risque de sécurité. En effet, ne pas mettre à jour votre application PHP, ou utiliser une application PHP qui n’est plus maintenue est généralement très dangereux. Les bonnes pratiques de sécurité évoluent régulièrement, donc une application PHP non mise à jour depuis plusieurs mois peut avoir des failles de sécurité.

Comment changer votre version de PHP ?

La procédure pour changer votre version de PHP est simple et ne présente pas de risque.

  1. Connectez-vous à votre interface cPanel
  2. Dans la partie “LOGICIEL” de cPanel, cliquez sur “Sélectionner une version de PHP”
  3. Cliquez sur la version actuelle de PHP puis choisissez la nouvelle version de PHP que vous souhaitez utiliser
  4. Cliquez sur “Set as current” pour confirmer votre choix
  5. Pour utiliser les extensions recommandées par Monarobase pour cette nouvelle version de PHP, cliquez sur “Reset to default” (en haut à droite)
  6. Et pour finir, nous recommandons de vérifier aussi les “Options” de PHP en cliquant sur l’onglet Options, nous recommandons de recopier la configuration suivante (sans modifier include_path et session.save_path) :
  7. Vérifiez si votre site continue à fonctionner correctement. Si ce n’est pas le cas, recommencez avec une version de PHP un peu moins récente, et si aucune version ne fonctionne revenez à votre version originale de PHP et contactez notre assistance pour demander conseil.

Laisser un commentaire